В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
TEMOXAA
TEMOXAA
26.07.2021 16:35 •  Информатика

Составить программу, которая находит наименьшее количество множителей ряда 1,5*1,8*2,1*2,4* … , произведение которых превышает число 10

Показать ответ
Ответ:
Smekalenok
Smekalenok
02.04.2023 05:20

"...напечатает сначала 2, потом - 6" -- это значит a=2 и b=6?


про пятеричные записи ничего не понял...  :) И ИМХО к чему такие сложности? И для чего нам комп и программа? Я подправил исходную прогу чтобы она выдавала все числа подходящие по условию

var x,a,b: longint;


begin

   for var i := 999 DownTo 100 do begin

       a := 0;

       b := 1;

       x := i;

       while x>0 do begin

           if x mod 2 > 0 then a := a+1 else b := b+(x mod 5);

           x := x div 5;

       end;

       if (a = 2) and (b = 6) then writeln('x = ', i, ' a = ', a, ' b = ',b);

   end;

end.


прога проводит расчет для всх трехзначных чисел от 999 до 100

итого мы видим что максимальное подходящее число это 960

при необходимости прогу можно переделать чтобы она находила только максимальное число.

0,0(0 оценок)
Ответ:
NoirShade
NoirShade
22.02.2023 00:06

розгалуження виконується, коли виконання попереднього розгалуження ще не закінчено.

Наприклад, вам потрібно встановити будильник на завтра. Якщо

завтра робочий день, то ви повинні встати о 7-й годині ранку, щоб іти

до школи. Якщо завтра субота, то ви повинні встати о 8-й годині ранку, щоб їхати на заняття гуртка. Якщо завтра неділя, то ви встаєте о

9-й годині ранку.

У наведеному на малюнку алгоритмі друге розгалуження з

умовою Завтра субота? міститься всередині першого розгалуження з

умовою Завтра робочий день?.

Такий фрагмент алгоритму називають вкладеним розгалуженням.

Вкладені розгалуження - це фрагмент алгоритму, у якому одне

розгалуження міститься всередині іншого розгалуження.

Розглянемо виконання наведеного на малюнку 3.26 фрагмента алгоритму. Спочатку перевіряється умова Завтра робочий день?. Якщо

результат перевірки цієї умови Так, то виконується команда Установити будильник на 7-му годину ранку і на цьому виконання всього

цього фрагмента алгоритму закінчується. Якщо результат перевірки

умови Завтра робочий день? - Ні, то перевіряється умова Завтра субота?. Якщо результат перевірки цієї умови Так, то виконується команда

Установити будильник на 8-му годину ранку і на цьому виконання всього цього фрагмента алгоритму закінчується, а якщо результат перевірки

цієї умови Ні, то виконується команда Установити будильник на 9-ту

годину ранку і виконання всього цього фрагмента алгоритму закінчується.

У наведеному на малюнку

фрагменті алгоритму внутрішнє

розгалуження виконується, якщо результат перевірки умови зовнішнього розгалуження Ні.

Объяснение:

рисунок 3.26 (во вложении)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота