В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
ЯнаZL
ЯнаZL
08.07.2022 00:51 •  Информатика

Составить программу, которая создает и заполняет массив а из 7 целых чисел случайными значениями в диапазоне от 2 до 100. вывести массив на экран. определить количество элементов массива а, являющихся простыми числами. для определения, является ли элемент массива простым числом описать функцию, возвращающую логическое значение «true», если это простое число, и «false», если элемент массива не является простым числом

Показать ответ
Ответ:
he11sp0re
he11sp0re
08.10.2020 06:14
На скриншотах
0,0(0 оценок)
Ответ:
ЯковНосков
ЯковНосков
08.10.2020 06:14
var    
        A, num: array[1..999] of integer;
        k, kk: integer;

function SN(c: integer): boolean;
begin
        for var j := 2 to 9 do begin
            if c mod num[j] <> 0 then
                inc(k);
        end;
        if k = 8 then begin
            SN := true;
            inc(kk);
        end else if k <> 8 then
             SN := false;
        k := 0;
end;

begin
    for var i := 2 to 9 do
         num[i] := i;
    for var i := 1 to 7 do begin
         A[i] := random(2, 200);
        writeln(A[i] + ' ');
        writeln(SN(A[i]));
    end;
    writeln(kk);
end.

Составить программу, которая создает и заполняет массив а из 7 целых чисел случайными значениями в д
Составить программу, которая создает и заполняет массив а из 7 целых чисел случайными значениями в д
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота