В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
idiotizROSSII
idiotizROSSII
28.07.2020 02:40 •  Информатика

Составить программу, которая вводит координаты точки (x, y) и определяет, попадает ли точка в заштрихованную область. (PascalABC)

Показать ответ
Ответ:
Gavka1
Gavka1
02.02.2021 04:17

ответ:«Компьютер» сөзі ағылшын тілінен аударғанда есептеуіш , есептеуге арналған құрылғы дегенді білдіреді. Компьютерлер есептеу операцияларының қатарларын адамның қатысуынсыз, алдын ала көрсетілген нұсқаулық – бағдарлама бойынша жүргізуге мүмкіндік береді. Есептеуіш техниканың қазіргі тарихының негізі 1943 жылы «Марк-1» машинасының дүниеге келуінен бастап қаланды. Компьютерлердің алдыңғы буындары шамдық есептеуіш машиналар болатын, олардың орнын транзисторлы электронды есептеуіш машиналар (ЭЕМ), содан кейін – интегралды сызбалар пайдаланылатын электронды есептеуіш машиналар және ең ақырында, қазіргі таңда аса үлкен интеграциялық деңгейлі сызбалар пайдаланылатын ЭЕМ басты.

Негізгі принциптері: Өзінің алдына қойылған тапсырманы орындау үшін компьютер механикалық бөліктердің орын ауыстырылуын, электрондардың, фотондардың, кванттық бөлшектердің ағынын немесе басқа да жақсы зерттелген физикалық құбылыс әсерлерін қолданады. Көбімізге компьютерлердің ең көп таралған түрі — дербес компьютер жақсы таныс.

Компьютер архитектурасы алға қойылған мәселені, зерттеліп отырған физикалық құбылысты максималды айқын көрсетіп, модельдеуге мүмкіндік береді. Мысалы, электрондық ағындар бөгеттер салу кезіндегі су ағынының үлгісі ретінде қолданылуы мүмкін. Осылай құрастырылған аналогтық компьютерлер XX ғасырдың 60-жылдары көп болғанымен, қазір сирек кездеседі.

Қазіргі заманғы компьютерлердің басым бөлігінде алға қойылған мәселе әуелі математикалық терминдерде сипатталады, бұл кезде барлық қажетті ақпарат екілік жүйеде (бір және ноль ретінде) көрсетіледі, содан кейін оны өңдеу үшін қарапайым логика алгебрасы қолданылады. Іс жүзінде барлық математикалық есептерді бульдік операциялар жиынына айналдыруға болатындықтан, жылдам жұмыс жасайтын электронды компьютерді математикалық есептердің, сонымен қатар, ақпаратты басқару есептерінің көпшілігін шешу үшін қолдануға болады.

Бірақ, компьютерлер кез келген математикалық есепті шеше алмайды. Компьютер шеше алмайтын есептерді ағылшын математигі Алан Тьюринг сипаттаған болатын.

Орындалған есеп нәтижесі пайдаланушыға әр түрлі енгізу-шығару құрылғыларының көмегімен көрсетіледі, мысалы, лампалық индикаторлар, мониторлар, принтерлер және т.б.

Компьютер — жай ғана машина, ол өзі көрсетіп тұрған сөздерді «түсінбейді» және өз бетінше «ойламайды». Компьютер тек қана бағдарламада көрсетілген сызықтар мен түстерді енгізу-шығару құрылғыларының көмегімен механикалық түрде көрсетеді. Адам миы экрандағы көріністі қабылдап, оған белгілі бір мән береді.

Объяснение:

0,0(0 оценок)
Ответ:
Мюсли004
Мюсли004
05.10.2020 08:14
Дешифровка: ВХОД_ОТКР Ы Т.

дешифровки:
Const sh = '_.,';
Var
  St : String;
  i  : Integer;
Function DeCode(S : String; Tabl : String; k : Integer) : String;
Var j,n : Integer;
Begin
  For j:=1 to Length(S) do
  Begin
    n:=Pos(S[j],sh);
    If n>0 then
    Begin
      n:=n+k;
      While n>Length(sh) do n:=n-Length(sh);
      While n<=0 do n:=n+Length(sh);
      S[j]:=sh[n];
    end
  end;
  DeCode:=S;
end;
Begin
  St:='ЗЫФЙГФШРЦ . ШД';
  Writeln(Decode(St,sh,-6));
  //For i:=-10 to 10 do Writeln(Decode(St,sh,i));
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота