В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Foolrelax
Foolrelax
26.01.2020 16:01 •  Информатика

Составить программу на языке pascal для решения следующей : дана строка. заменить в этой строке все буквы «о» на буквы «а». если букв «о» не встречено в строке, то вывести на экран сообщение «нет буквы «о»

Показать ответ
Ответ:
arinakirkot
arinakirkot
02.04.2022 19:20
1. Не знаю. Вопрос точно правильно написан?
2. в.пиксель
3. а.красный, синий, зеленый
4. а.хранения информации о цвете каждого пикселя экрана монитора
5. г.программа для создания и редактирования рисунков
6. б.графических примитивов
7.б. растровой графики
8. а.электронное устройство для хранения двоичного кода изображения, выводимого на экран
9.  а.дисплейный процессор и видеопамять(немного есть сомнения)
10. в. bmp
11.Разрешающая сканера 300 dpi (dot per inch - точек на дюйм) означает, что на отрезке длиной 1 дюйм сканер различить 300 точек.
Переведем разрешающую сканера из точек на дюйм (1 дюйм = 2,54 см) в точки на сантиметр:
300dpi : 2,54 ≈ 118 точек/см.
Следовательно, размер изображения в точках составит
25*118 и 30*118 = 2950х3540
Общее количество точек изображения равно:
2950 * 3540 = 10 443 000.
Информационный объем файла равен:
3 байта= 24 бита. 24 * 10 443 000 = 250632000 бит = 31329000 байт = 30595 Кб ≈ 30 Мб
12.65536 означает, что на каждый пиксель отводится два байта. Итого имеем 1280*2КБ=2,5МБ.
0,0(0 оценок)
Ответ:
TemhenkoShasa
TemhenkoShasa
02.04.2023 18:38

program tsveti;

var x,y,z,w:integer;

begin

   write('Введите количество девочек: '); readln(x);

   write('Введите количество цветов: '); readln(y);

   if (y div x) mod 2 = 0 then begin // здесь мы проверяем, не получается ли чётное количество цветков, и если получается чётное, то вычитаем остаток и количество девочек, чтобы добиться нечётного количества

       w := y mod x + x;

       z := (y - w) div x;

   end

   else begin

       w := y mod x;

       z := y div x;

   end;

   writeln('Девочкам подарили по ', z, ' шт. цветков.');

   writeln('Осталось ', w, ' шт. цветков.');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота