Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
RETYUOP
02.02.2020 04:07 •
Информатика
Составить программу, считывает 2 числа, если сумма этих чисел кратно 3, то результат уменьшает в 3 раза, в противном случае оставляет без изменений.
Показать ответ
Ответ:
asdf37
07.10.2020 19:49
На c++, если тебе надо считывание с файла, то ответь я переделаю.
#include <iostream>using namespace std;int main(){ int a,b; cin>>a>>b; if((a+b)%3==0) cout<<(a+b)/3<<endl; else cout<<a+b<<endl; return 0;}
0,0
(0 оценок)
Ответ:
максим1503889900
07.10.2020 19:49
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b):=ReadInteger2('Введите через пробел два числа');
var r:=a+b;
if r mod 3=0 then Writeln(r/3)
else Writeln(r)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
RealPacani
23.06.2022 21:33
Изменить программу, чтобы работала в Паскале: ConstSz=100;Vari: Integer;a:array[1..Sz]of integer;N:Integer ;BeginN:=20;For i:=1 to N do a[i]:=random (100);WriteLn( Эл. массива...
balbasenok
04.07.2021 23:53
1.Начертите на бланке структуру базы данных Картинная галерея , содержащую сведения о полотнах выдающихся художников. Укажите необходимые имена полей и их типы данных. Задайте...
tomikyrmash
14.05.2023 14:49
1)Перед началом забега на 1 км было высказано два прогноза о результатах фаворитов cоревнований: 1) Сидоров будет первым, Иванов - вторым, Петров - третьим. 2) Победит Иванов,...
jeviduwel
29.07.2020 21:53
Двумерный массив размера n*n сформировать случайными числами от 0 до 10. Найти произведение ненулевых элементов массива, находящихся выше главной диагонали. Размерность...
KaterinaReyn
29.11.2022 21:51
сканируется цветное изображение размером 5,08 = 5,08дюйм. Разрешающая сканера 43,18×43,18dpi, глубина цвета — 8. Какой информационный объем будет иметь полученный графический...
viginipinigivini
02.04.2020 05:12
В фрагменте базы данных представлены сведения о родственных отношениях. Таблица 1 ID Фамилия_И.О. Пол 2011 Косач-Квитка Л.П. Ж 2012 Левитан И.И. М 2024...
sevliekaterina2
13.09.2020 07:55
Информатика задания из ОГЭ....
jak15
13.09.2020 07:55
Напишите программу, в которой осуществляется ввод целых чисел и подсчет суммы и среднего арифметического введённых положительных чисел. Рассмотрите два случая: 1) количество...
raupova74
16.02.2022 04:35
Cоставление блок-схем к стихотворению М.Ю. Лермонтова «Парус», к стихотворению С. Есенина «Черёмуха» ПАРУС Белеет парус одинокой В тумане моря голубом!.. Что ищет он в стране...
02Milka02
18.11.2022 19:49
Выпаровування и Конденсация Насичени и не насичени пари...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <iostream>using namespace std;int main(){ int a,b; cin>>a>>b; if((a+b)%3==0) cout<<(a+b)/3<<endl; else cout<<a+b<<endl; return 0;}
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b):=ReadInteger2('Введите через пробел два числа');
var r:=a+b;
if r mod 3=0 then Writeln(r/3)
else Writeln(r)
end.