В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Составить программу в которой пользователь вводит последовательность которая оканчивается на 0 .в количество чисел кратных 3 и оканчивающихся на 7​

Показать ответ
Ответ:
скарабец
скарабец
04.07.2021 19:24

//Написал простейшую программу для наглядного примера. Суть в том, что ограничено число попыток ввода неправильного пароля

//attempts - количество попыток, counter - счетчик неудачных попыток


const

  attempts = 3;

  password = '12345';

   

var

  counter: integer;

  str: string;

   

begin

  counter := 0;

   

  repeat

     write('Введите пароль: ');

     readln(str);

     

     if not(str = password) then

     begin    

        counter := counter + 1;

        writeln('[неверный пароль] осталось попыток: ', attempts - counter);

        writeln();

     end;

         

     if (counter = attempts) then

     begin

        writeln('Попытки ввода закончились!');

        break;

     end;

   

  until (str = password);

   

  if (str = password) then

     writeln('Вы ввели правильный пароль!');

end.


Как ограничить количество попыток ввода в паскаль?
0,0(0 оценок)
Ответ:
atamanova91
atamanova91
08.02.2022 13:11

//В строку location введите расположение требуемого файла

//Если хотите задавать расположение файла в ходе работы программы, то нужно будет убрать const со строки location

//Язык C#


using System;

using System.IO;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           const string location = "E://Test//File.txt";

           try

           {

               Console.WriteLine("Количество чисел, которые не делятся на 3: " + ReadFile(location));

           }

           catch (Exception)

           {

               Console.WriteLine("Ошибка (файл недоступен, либо содержит некорректный формат данных)!");

           }

           

           finally

           {

               Console.ReadKey();

           }

       }

       static int ReadFile(string location)

       {

           int counter = 0;

           StreamReader fileReader = new StreamReader(location);

           while (!fileReader.EndOfStream)

           {

               string num = fileReader.ReadLine();

               if (Convert.ToInt32(num) % 3 != 0)

                   counter++;

           }

           return counter;

       }

   }

}


Дан файл, который содержит целые ненулевые числа, которые оканчиваются нулем. найти количество чисел
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота