В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
latifa5
latifa5
18.05.2022 08:59 •  Информатика

Составьте программу, которая формирует массив из двадцати случайных целыъ от -15 до 15 и уменьшает в 3 раза числа, кратные 3, а остальные увеличивает в 2 раза

Показать ответ
Ответ:
Anna1011qpqq
Anna1011qpqq
09.10.2020 15:38

var a:array[1..20] of integer;

i: integer;

begin

write(' Исходный массив: ');

for i:=1 to 20 do

begin

a[i]:=random(31)-15;

write (a[i]:3,' ')

end;

writeln;

write('Преобразованый массив: ');

for i:=1 to 20 do

begin

if (a[i] mod 3 = 0) then a[i]:=a[i] div 3

else a[i]:= a[i]*2;

write (a[i]:3,' ')

end

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота