В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
denishustov
denishustov
28.04.2022 13:25 •  Информатика

составьте программу которая обеспечивает ввод текста на экран по смыслу текста самая верхняя строка слева самая верхняя строка справа,самая верхняя строка посередине,самая нижняя строка слева, самая нижняя строка слева,строка в центре справа,строка в центре посередине

Показать ответ
Ответ:
elina080
elina080
11.01.2022 14:39

2) Вопрос не понял, но думаю правильно ответил:

var a,b,c,d :int64;

begin

readln(a);

b := a -1;//число до  

c := a +1;//число след.

writeln('Число до: ',b,' Число след.: ',c);

end.

3)

var a,b,c,d :int64;

begin

readln(a);//Кол-во учеников

readln(b);//Кол-во яблок

c := b div a;//Яблок каждому ученику

d := b - (a * c);//Яблок в корзине  

writeln('Яблок каждому: ',c,' Яблок осталось в корзине: ',d);

end.

4)

var a,b,c,d:int64;

begin

readln(a);//Число

b := a mod 10;//остаток от деления

c := a div 10;//деление без остатка

d := c mod 10;//остаток от деления

writeln('При последнее число: ',d,' Последнее число: ',b);

end.

5)

var a,b,c,d:int64;

begin

readln(a);//Автобус за день  

readln(b);//Кол-во дней

c := a * b;

writeln('Автобус проехал: ',c,' (км)');

end.

6)

var a,b,c,d:int64;

begin

readln(a);//Путь муравья

b:= a div 1000;//м

c:= (a - (b*1000)) div 10;

//см

d:= a - (b*1000+c*10);

//мм

writeln('Путь муравья: ',b, ' (м) ',c,' (см) ',d,' (мм)');

end.

7)

var a,b,c,d:int64;

begin

readln(a);//Грань куба

b := a*a*a ;

writeln('Объем куба: ',b, ' м^3');

end.

8)

var a,b,c,d,g:real;

begin

readln(a,c,d,b);//Числа

g:=(a+c+d+b) / 4 ;

writeln('Cреднее арифметическое: ', g);

end.

9)

var a,b,c,d:real;

begin

readln(a,b,c);//Учеников в кадом классе

d:= (a+b+c)/ 2;

writeln('Кол-во парт для 3 классов: ', d);

end.

Объяснение:Все программы написаны на Pascal.

Капец много задач за 5б)))

0,0(0 оценок)
Ответ:
evgenyzuzev
evgenyzuzev
15.03.2022 22:08

#include "stdafx.h" #include <conio.h> #define N 3 typedef struct { char name[25]; int tel[15]; int bday[3]; } NOTE; void setValue(NOTE blockNote[N]); void printValue(NOTE blockNote[N]); int _tmain(int argc, _TCHAR* argv[]) { NOTE blockNote[N]; setValue(blockNote); printValue(blockNote); return 0; } void setValue(NOTE blockNote[N]) { for(int i=0; i<N; i++) { printf("Enter name: "); gets_s(blockNote[i].name); printf("Enter tel: "); printf("%d", &blockNote[i].tel); printf("Enter bday (format: day.month.year): "); scanf_s("%d.%d.%d", &blockNote[i].bday[0], &blockNote[i].bday[1], &blockNote[i].bday[2]); printf("---\n"); } } void printValue(NOTE blockNote[N]) { for(int i=0; i<N; i++) printf("name: %s tel: %d bday: %d.%d.%d\n", blockNote[i].name, blockNote[i].tel, blockNote[i].bday[0], blockNote[i].bday[1], blockNote[i].bday[2]); }

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота