В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
GeorgHimik2005
GeorgHimik2005
28.03.2021 02:36 •  Информатика

Составьте программу в паскале при умножении на 4 четырехзначного числа, все цифры которого различны, получается число, записываемое теми же цифрами, но в обратном порядке. какое это число?

Показать ответ
Ответ:
nekit1o6
nekit1o6
22.03.2020 03:59

/*Создайте класс «Car» который позволяет рассчитать стоимость автомобиля  

* (с базовой стоимостью 309000)в зависимости от выбранной комплектации  

* (ABS-8390, противотуманные фары - 2960, парктроник 3500),

* если выбраны все опции -действует скидка в 5% от стоимости автомобиля.

*/

using System;

namespace restless

{

   class Car

   {

       private float _price;

       private bool _haveABS, _haveLight, _haveParkAssist;

       public Car()

       {

           _price = 309000;

           _haveABS = false;

           _haveLight = false;

           _haveParkAssist = false;

       }

       public void printPrice()

       {

           if (_haveABS == true && _haveLight == true && _haveParkAssist == true)

               Console.WriteLine($"Вам предоставляется скидка в 5% за покупку всех доп. опций, стоимость авто с учётом скидки: {_price * 1.05}");

           else

               Console.WriteLine($"Текущая стоимость авто {_price}");

       }

       public void setABS()

       {

           if (_haveABS == false)

           {

               _haveABS = true;

               _price += 8390;

               Console.WriteLine("Опция успешно добавлена!");

           }

           else

           {

               Console.WriteLine("Данная опция уже была добавлена!");

           }

       }

       public void setLigth()

       {

           if (_haveLight == false)

           {

               _haveLight = true;

               _price += 2960;

               Console.WriteLine("Опция успешно добавлена!");

           }

           else

           {

               Console.WriteLine("Данная опция уже была добавлена!");

           }

       }

       public void setParkAssist()

       {

           if (_haveParkAssist == false)

           {

               _haveParkAssist = true;

               _price += 3500;

               Console.WriteLine("Опция успешно добавлена!");

           }

           else

           {

               Console.WriteLine("Данная опция уже была добавлена!");

           }

       }

       public void addNewOptions()

       {

           string mchoice;

           Console.WriteLine("Какую опцию вы хотите добавить?\n1.ABS\n2.Противотуманные фары\n3.Парктроник");

           mchoice = Console.ReadLine();

           switch (mchoice)

           {

               case "1":

                   setABS();

                   break;

               case "2":

                   setLigth();

                   break;

               case "3":

                   setParkAssist();

                   break;

               default:

                   Console.WriteLine("Невернно введен номер опции");

                   break;

           }

       }

   }

   class Program

   {

       static void Main(string[] args)

       {

           int choice;

           Car vesta = new Car();

           do

           {

               Console.WriteLine("\n\t\tМеню\n1.Показать текущую стоимость авто\n2.Добавить опцию\n0.Выход");

               choice = Convert.ToInt32(Console.ReadLine());

               switch (choice)

               {

                   case 1:

                       vesta.printPrice();

                       break;

                   case 2:

                       vesta.addNewOptions();

                       break;

                   case 0:

                       Console.WriteLine("Программа завершена.");

                       break;

                   default:

                       Console.WriteLine("Неверно введен пункт меню");

                       break;

               }

           } while (choice != 0);

       }

   }

}

0,0(0 оценок)
Ответ:
UbisCraft
UbisCraft
22.03.2020 03:59

В давних литературных произведениях носители информации были на низком уровне. Основными носителями информации в те времена были: собственная биологическая память человека, бумага, камень, папирус, земля, песок и т.д. В каких литературных произведениях были использованы носители информации? - Повесть "Человек, который смеется"(злопамятный персонаж Баркильфедро, который решил отомстить подлым богачам, всегда запоминад только зло не видел светлых и жоьрых поступков); Былина - три поездки Илья Муромца, богатырь должен был выбрать путь из 3 предложенных, на трех камнях было написано что будет тебя ждать если ты выберешь тот или иной путь. Носитель информации - камень.; Сказка о царе Салтане..., тут источник информации бумага.

Обьяснение:

Носители информации - обьекты хранящие информацию. Они бывают статическими и динамическими. Понятие носители информации говорит само за себя. Раньше носителем информации была бумага и мозг человека. Пока не появились более надежные, долговечные и емкие носители. К примеру провод который проводит ток к компьютеру является динамическим носителем информации, т.к ток не стоит на месте, а передается. Статическими носителями информации являются жесткие и оптические диски, флэш-накопители и т.д. Так как данные хранятся, а не передаются.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота