В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
mariuaivanova1
mariuaivanova1
06.03.2021 21:29 •  Информатика

Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1 )использовать цикл с предусловием. 2 )использовать цикл с постусловием. 3 )использовать цикл с параметром.

Показать ответ
Ответ:
ashatsejtenov
ashatsejtenov
26.08.2020 20:06
Program sqr;
Var i:integer;
begin
  while i <= 50 do //1)
    begin
      write(i*i, ' ');
      Inc(i);
    end;
  i:=0;
  writeln;
  repeat         //2)
    write(i*i, ' ');
    Inc(i);
  until i > 50;
  writeln;
  for i:=1 to 50 do write(i*i, ' '); //3)
end.
0,0(0 оценок)
Ответ:
93angela93
93angela93
26.08.2020 20:06
2)#include<iostream>#include <stdlib.h>#include<math.h>using namespace std;int main(){int c=0, b;do{

    b = pow( c, 2);    c++;    cout << b << " ";}    while(c<51);    system("pause");
}

1)#include<iostream>#include <stdlib.h>#include<math.h>using namespace std;int main(){int c=0, b;
    while(c<51){

    b = pow( c, 2);    c++;    cout << b << " ";}    system("pause");
}
3)#include<iostream>#include <stdlib.h>#include<math.h>using namespace std;int main(){int c=0, b;
    for(c; c<51; c++){

    b = pow( c, 2);    cout << b << " ";}    system("pause");
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота