В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
aidnovna
aidnovna
05.03.2023 05:52 •  Информатика

Условие: Требуется написать программу которая в исходном трехзначном числе x меняют местами цифры сотен и десятков, единицы оставляет в исходном состоянии выводит полученное число.
Формат входных данных:
Входной поток содержит целое число (100< x <999)
Формат выходных данных:
Программа должна вывести трехзначное число - результат указанной перестановки цифр в числе x.

Показать ответ
Ответ:
11UmNiK111
11UmNiK111
04.10.2021 22:00

Программа написана на языке C# (.NET Framework)

- Если число должно выдаваться пользователем:

using System;

namespace ConsoleApp2

{

class Program

{

static void Main(string[] args)

{

while (true)

{

int o = Int32.Parse(Console.ReadLine());

if (o < 100 || o > 999)

{

Console.WriteLine("Ошибка!");

Console.ReadLine();

}

else

{

int a = o / 100,

b = (o / 10) % 10,

c = o % 10;

String x = Convert.ToString(b) + Convert.ToString(a) + Convert.ToString(c);

Console.WriteLine(x);

Console.ReadLine();

}

}

}

}

}

- Если число должно выдаваться с запуском программы:

using System;

namespace ConsoleApp2

{

class Program

{

static void Main(string[] args)

{

while (true)

{

Random rnd = new Random();

int o = rnd.Next(100, 999),

a = o / 100,

b = (o / 10) % 10,

c = o % 10;

String x = Convert.ToString(b) + Convert.ToString(a) + Convert.ToString(c);

Console.WriteLine(o);

Console.WriteLine(x);

Console.ReadLine();

}

}

}

}

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота