В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Natiman
Natiman
26.07.2021 20:36 •  Информатика

В dev c++ Дан массив размера N. Вывести массив на экран в строчку. Найти номер его первого локального максимума.
Локальный максимум – это элемент, который больше любого из своих соседей.
Входные данные размерность массива: 5 0 5 89 10 100
Выходные данные 0 5 89 10 100
Номер элемента массива, первого локального минимума - 3

Показать ответ
Ответ:
stasbrega
stasbrega
15.10.2020 13:53

#include <iostream>

int main() {

using namespace std;

setlocale(LC_ALL, "Russian");

int N;

cout << "Введите размерность массива: ";

cin >> N;

int* A = new int[N];

for (int i = 0; i < N; i++)

{

 cout << "Заполните [" << i + 1 << "] элемент: ";

 cin >> A[i];

}

cout << endl;

for (int i = 0; i < N; i++)

{

 cout << A[i] << " ";

}

int max_index = 0;

for (int i = 1; i < N; i++)

{

 if (A[i] > A[max_index]) {

  max_index = i;

 }

}

cout << "\nНомер локального максимума: " << max_index + 1;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота