В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
KUGOTVIN
KUGOTVIN
01.05.2023 17:37 •  Информатика

Вычислить сумму натуральных чисел от 1 до n . составить программу нахождения кол-ва делителей числа n ( значение n вводится с клавиатуры )

Показать ответ
Ответ:
Markiza11
Markiza11
19.07.2020 06:58
Держи!
1)
var i,n,result:integer;
begin
read(n);
result:=0;
for i:=1 to n do
begin
   result:=result+i;
end;
write(result);
end.

2)
var i,n,increase,result:integer;
massive = array[1..1000] of integer;// ищем делители в диапазоне 1-1000
begin
read(n);
for i:=1 to 1000 do
begin
   if((n mod massive[i])=0) then
   begin
       increase:=increase + 1;
   end;
end;
result:=increase;
write(result);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота