Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
takeoff
17.02.2022 11:04 •
Информатика
Задан массив, который содержит 15 целых чисел. Найти произведение положительных элементов массива НА ЯЗЫКЕ С++
Показать ответ
Ответ:
liza20038333
29.09.2020 05:41
Var
i, n, s: integer;
begin
readln(n);
i := 0;
s := 0;
while i < 7 do
begin
if (n mod 2 = 1) then begin
s := s + n;
i := i + 1;
end;
n := n + 1;
end;
writeln(s);
end.
var
i, n, s: integer;
begin
readln(n);
i := 0;
s := 0;
repeat
if (n mod 2 = 1) then begin
s := s + n;
i := i + 1;
end;
n := n + 1;
until i >= 7;
writeln(s);
end.
var
i, n, s: integer;
begin
readln(n);
n := n + (n + 1) mod 2;
s := 0;
for i := 1 to 7 do
begin
s := s + n;
writeln(n);
n := n + 2;
end;
writeln(s);
end.
0,0
(0 оценок)
Ответ:
annagrits66
31.07.2022 03:14
1)
var
s: string[6];
n: integer;
begin
s := 'отлично';
n := length(s);
writeln(length('отлично'));
writeln(n);
end.
Изначально выставлен тип string[6], значит если присвоить строку больше, то ее обрежет по 6 символов, вот и весь прикол
ответ 6
2) рисунок
3)var
s, s1: string;
n: integer;
begin
s := 'информатика';
s1 := copy(s, 3, 5);
n := pos(s, s1);
writeln('s=', s);
writeln('s1=', s1);
writeln('n=', n);
end.
Вывод
s=информатика
s1=форма
n=0
Все верно, в s1 не содержится s, а наоборот
0,0
(0 оценок)
Популярные вопросы: Информатика
вадимм2
18.05.2020 13:14
Создать список любимых фильмов и вывести тремя массив...
PolinaFox6002
19.06.2022 21:42
составить код в Python 1) Определите по номеру года, является или нет этот год високосным. Указание: год считается високосным, если номер этого года делится нацело на 4,...
Y563280
18.02.2021 12:56
Текст длинной 32768 символов закодирован с алфавита, содержащего 64 символа. сколько килобайт занимает в памяти этот текст?...
hameleon5
06.10.2021 11:51
1)програма у середовищі скретч називаеться? а)набір команд б)скрипт в)завдання г)файл2)що таке алгоритм ?а)конструктор б)перелік дій в)послідовність команд г)розповідне речення...
mugivara9820p09uk7
12.08.2021 14:46
Соч по информатике 6 класс 4 четверть отмечу как лучший ответ и ...
Алжсжсзвьвлвждчяь
07.03.2022 05:46
как написать программу на языке c++ которая находит сумму минимального нечетного числа и максимального четного числа...
natalipanshina
24.01.2023 20:48
Даны три целых числа, каждое записано в отдельной строке. Выходные данные:выведите эти числа в порядке неубывания.(python)...
школаскучаю
29.07.2022 16:48
Посоветуйте на каком сайте (приложении) можно хорошо обучиться Python с нуля. Очень нужно только проверенные сайты(приложения)...
шкиль1
07.04.2021 05:32
Укажите варианты ответов,в которых в обоих словах одного ряда пропущена одна и та же буква. 1)вышаг..вать,насмешл..вый. 2)фасолевый,накрасмал..ть. 3)обрад..вать,мех..вой....
НикаМарьям
07.04.2021 05:32
Для многих известных людей творческий путь путь к открытиям начинался со школы,где учителя смогли разглядеть их таланты. знаки препинания правильны?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
i, n, s: integer;
begin
readln(n);
i := 0;
s := 0;
while i < 7 do
begin
if (n mod 2 = 1) then begin
s := s + n;
i := i + 1;
end;
n := n + 1;
end;
writeln(s);
end.
var
i, n, s: integer;
begin
readln(n);
i := 0;
s := 0;
repeat
if (n mod 2 = 1) then begin
s := s + n;
i := i + 1;
end;
n := n + 1;
until i >= 7;
writeln(s);
end.
var
i, n, s: integer;
begin
readln(n);
n := n + (n + 1) mod 2;
s := 0;
for i := 1 to 7 do
begin
s := s + n;
writeln(n);
n := n + 2;
end;
writeln(s);
end.
var
s: string[6];
n: integer;
begin
s := 'отлично';
n := length(s);
writeln(length('отлично'));
writeln(n);
end.
Изначально выставлен тип string[6], значит если присвоить строку больше, то ее обрежет по 6 символов, вот и весь прикол
ответ 6
2) рисунок
3)var
s, s1: string;
n: integer;
begin
s := 'информатика';
s1 := copy(s, 3, 5);
n := pos(s, s1);
writeln('s=', s);
writeln('s1=', s1);
writeln('n=', n);
end.
Вывод
s=информатика
s1=форма
n=0
Все верно, в s1 не содержится s, а наоборот