В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Тосямдр
Тосямдр
01.11.2022 17:49 •  Информатика

Задание #3
Во Какая последовательность символов не может служить именем в языке Паскаль?
Выберите один из 4 вариантов ответа:
1) _mas 2) maS1 3) d2 4) 2d
Задание #4
Во Вещественные числа имеют тип данных:
Выберите один из 4 вариантов ответа:
1) real 2) integer 3) Boolean 4) string
Задание #5
Во В программе на языке Паскаль обязательно должен быть:
Выберите один из 4 вариантов ответа:
1) заголовок программы
2) блок описания используемых данных
3) программный блок
4) оператор присваивания
Задание #6
Во Какого раздела не существует в программе, написанной на языке Паскаль?
Выберите один из 4 вариантов ответа:
1) заголовка 2) примечаний
3) описаний 4) операторов
Задание #7
Во Языковые конструкции, с которых в программах записываются действия,
выполняемые в процессе решения задачи, называется:
Выберите один из 4 вариантов ответа:
1) операндами 2) операторами
3) выражениями 4) данными
Задание #8
Во Разделителями между операторами служит:
Выберите один из 4 вариантов ответа:
1) точка 2) точка с запятой 3) пробел 4) запятая
Задание #9
Во Описать переменную - это значит указать её:
Выберите один из 4 вариантов ответа:
1) имя и значение 2) имя и тип
3) тип и значение 4) имя, тип и значение
Задание #10
Во В данном фрагменте программы:
program error;
begin
suMma: = 25-14;
end.
ошибкой является:
Выберите один из 4 вариантов ответа:
1) некорректное имя программы 2) не определенное имя переменной
3) некоректное имя переменной 4) запись арифметического выражения
Задание #11
Во Какая клавиша нажимается после набора последнего данного в операторе read?
Выберите один из 4 вариантов ответа:
1) enter 2) точка с запятой 3) пробел 4) ctrl
Задание #12
Во При присваивании изменяется:
Выберите один из 4 вариантов ответа:
1) имя переменной 2) тип переменной
3) значение переменной 4) значение константыЗадание #13
Во Для вывода результатов в Паскале используется оператор:
Выберите один из 4 вариантов ответа:
1) begin 2) readln 3) write 4) print
Задание #14
Во Для вычисления квадратного корня из x используется функция:
Выберите один из 4 вариантов ответа:
1) abs (x) 2) sqr (x) 3) sqrt (x) 4) int (x)
Задание #15
Во В каком из условных операторов допущена ошибка?
Выберите один из 4 вариантов ответа:
1) if b=0 then writeln ( 'Деление невозможно.' ) ;
2) if a
3) if a>b then max : = a else max := b ;
4) if (a>b) and (b<0) then c : = a+b ;
Задание #16
Во В условном операторе и после then и после else нельзя использовать:
Выберите один из 5 вариантов ответа:
1) оператор вывода 2) составной оператор
3) несколько операторов 4) условный оператор
Задание #17
Во Определите значение переменной "c" после выполнения следующего фрагмента программы:
a : = 100 ;
b : = 30;
a : = a - b*3 ;
if a > b then c : = a - b else c : = b - a ;
Выберите один из 4 вариантов ответа:
1) 20 2) 70 3) -20 4) 180
Задание #18
Во Условный оператор
if a mod 2=0 then write ( 'Да') else write ('Нет') позволяет определить, является ли число a:
Выберите один из 4 вариантов ответа:
1) целым 2) двухзначным 3) четным

Показать ответ
Ответ:
linaaalinaa
linaaalinaa
26.01.2021 04:32

ответ:

uses crt;

var a: array[1..20,1..20] of real;

    n,m,i,j: integer;

    s: real;

begin

    clrscr; randomize;

    write('введите кол-во строк: '); readln(n);

    write('введите кол-во столбцов: '); readln(m);

    for i: =1 to n do

    begin

      for j: =1 to m do

      begin

        a[i,j]: =random(100)/10;

        write(a[i,j]: 4: 1);

      end;

      writeln;

    end;

    for i: =1 to n do

    begin

      s: =0;

      for j: =1 to m do

      s: =s+a[i,j];

      writeln('сумма ',i,'-ой строки: ',s: 0: 1);

    end;

    for j: =1 to m do

    begin

      s: =0;

      for i: =1 to n do

      s: =s+a[i,j];

      writeln('сумма ',j,'-ого столбца: ',s: 0: 1);

    end;

    for j: =1 to m do

    begin

      s: =0;

      if j mod 2 = 0 then  

      begin

        for i: =1 to n do

        s: =s+a[i,j];

        writeln('среднее арифметическое ',j,'-ого столбца: ',s/m: 0: 1);

      end;

    end;

    readln;

end.

объяснение:

0,0(0 оценок)
Ответ:
vulf20
vulf20
04.04.2023 20:58

ответ:

объяснение:

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

const n=23; m=40; //n-ряды, m-места

var

  a: array[1..n,1..m] of integer; //зрительный зал

  i,j,k: integer;

begin

  randomize;

  writeln('зрительный зал: ');

  write('м/р');

  for i: =1 to m do write(i: 3);

  writeln;

  for i: =1 to n do begin

    write(i: 3);

    for j: =1 to m do begin

      a[i,j]: =ord(random(10)> 0); write(a[i,j]: 3); //read(a[i,j]); я ввожу гадалкой, т.к. руками вбивать 920 цифирь не входит в мое понятие героизма

    end;

    writeln;

  end;

  repeat

    write('в каком ряду смотреть свободные места? ');

    readln(i);

  until (i> 0) and (i

  k: =0;

  for j: =1 to m do k: =k+ord(a[i,j]=0); //cчитаем свободные места

  write('в ряду ',i);

  if k> 0 then writeln(' есть свободные места в количестве ',k,' шт.') else

  writeln(' свободных мест нет');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота