В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Tuchka2oo5
Tuchka2oo5
08.09.2022 11:22 •  Информатика

Напишите программу (паскаль или c++, желательно c++) которое читает n-ое количество чисел и выводит на экран число нолей в конце произведения этих чисел, без того чтобы посчитать произведение. пример: 10 12 15 254 525 56 125 500 105 48 912 ответ: 10

Показать ответ
Ответ:
Lenazakhozhenk
Lenazakhozhenk
19.11.2022 16:30
Биполярный транзистор состоит из трех областей: эмиттера, базы и коллектора, на каждую из которых подается напряжение. В зависимости от типа проводимости этих областей, выделяют n-p-n и p-n-p транзисторы. Обычно область коллектора шире, чем эмиттера. Базу изготавливают из слаболегированного полупроводника (из-за чего она имеет большое сопротивление) и делают очень тонкой. Поскольку площадь контакта эмиттер-база получается значительно меньше площади контакта база-коллектор, то поменять эмиттер и коллектор местами с смены полярности подключения нельзя. Таким образом, транзистор относится к несимметричным устройствам.
0,0(0 оценок)
Ответ:
godday
godday
07.06.2021 23:10
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var (n,m):=ReadInteger2('Количество строк и столбцов в матрице:');
  Writeln('*** Исходная матрица ***');
  var rmatr:=MatrRandom(n,m,-99,99);
  rmatr.Println(4); Writeln(4*m*'-');
  var max:=rmatr.ElementsByRow.Max;
  var s:=0;
  foreach var row in rmatr.Rows do
    if row.Contains(max) then s+=row.Sum;
  Writeln('Сумма равна ',s)
end.

Пример
Количество строк и столбцов в матрице: 8 7
*** Исходная матрица ***
 -50 -48   6   5  54 -16  42
 -96 -23 -35  46 -39 -44 -15
   2 -67  99  50 -53  68 -61
 -77 -13 -76 -59  38 -20   4
  97 -82  -1  20 -81 -77  -2
 -51  87  34  -5  14 -60  91
 -53  24   2  98 -98  29 -84
  60  28  18  68   8  28 -73

Сумма равна 38
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота