В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
helenawoy
helenawoy
04.04.2023 05:24 •  Информатика

Нужно в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. в конце работы программы на экран выводится сумма и произведение введенных чисел (не считая 0).

Показать ответ
Ответ:
figa333
figa333
10.10.2020 01:53

Program n_1;

var a, b, n: double;

begin

   read (n);

   a:=n; b:=n;

   if n<>0 then read (n);

   while (n<>0) do begin

       a:=a+n;

       b:=b*n;

       read(n);

   end;

   writeln('Сумма чисел равна ', a:0:10, ' а их произведение ', b:0:10);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота