В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Sashka15081
Sashka15081
04.12.2021 21:44 •  Информатика

Pascalabc. составьте программу, которая формирует массив из 15 случайных целых чисел, каждое из которых находится в диапазоне от -10 до 10 и выводит на экран: а) максимальный элемент массива б) индекс максимального элемента массива

Показать ответ
Ответ:
Chumaeva79
Chumaeva79
09.10.2020 19:07

program fantscrin;

 const n = 15;

 var a: array [1..n] of integer;

     i,max,max_i:integer;

Begin

 for i:=1 to n do

   a[i]:= random(21)-10;

 for i:=1 to n do

   write(a[i], '  ');

   

 max:=a[1];

 max_i:=1;

 for i:=2 to n do

   if (a[i]>max) then  

                 begin

                   max:=a[i];

                   max_i:=i;

                 end;

 writeln('');

 writeln('Элемент: ', max);

 writeln('Индекс: ', max_i);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота