В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Anopsis
Anopsis
04.10.2022 11:53 •  Информатика

Составьте программу печати таблицы температур по цельсию от 0 до градусов с шагом в один градус и их эквивалентов по шкале фаренгейта используя для перевода формулу tf=9tc/5+32

Показать ответ
Ответ:
pro9377196
pro9377196
05.07.2020 12:20
var
  max, i: integer;
  
begin
  readln(max);
  for i := 0 to max do
    writeln(i:3, chr(0176), 'C | ', 9 * i / 5 + 32, chr(0176), 'F');
end.

Элементарная домашка... Не знаю, прочтёт ли это кто-нибудь, но...
Считываем верхнюю границу вывода (ибо в условии с ней заминка), а затем в столбик выводим... chr() возвращает символ по коду, а 176 - код градуса
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота