В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dovlarisa
dovlarisa
28.04.2021 17:08 •  Информатика

Вс++ составить программу нахождения числа строк матрицы а(6,6), максимальный элемент которых больше р

Показать ответ
Ответ:
sashka1281
sashka1281
20.08.2020 17:27
#include <iostream>
using namespace std;

int main() {
  const int S = 6;
  int matrix[S][S];
  cout << "Введите матрицу построчно, разделяя пробелами: " << endl;
  for (int i = 0; i < S; i++) {
    for (int j = 0; j < S; j++) {
      cin >> matrix[i][j];
    }
    cout << endl;
  }
  int p;
  cout << "p = ";
  cin >> p;
  int count = 0, max;
  for (int i = 0; i < S; i++) {
    max = matrix[i][0];
    for (int j = 1; j < S; j++) {
      if (matrix[i][j] > max) max = matrix[i][j];
    }
    if (max > p) count++;
  }
  cout << endl << "ответ: " << count;
  return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота